No announcement yet.

MT4 Crash error on Macbook Pro

  • Filter
  • Time
  • Show
Clear All
new posts

  • MT4 Crash error on Macbook Pro

    Hi Guys,

    I was wondering if anyone here is running MT4 on Macbook Pro. Every time i launch MT4 I get an error mentioning:

    Program Error_
    The program terminal.exe has encountered a serious problem and needs to close. We are sorry for the inconvenience.

    This can be caused by a problem in the program or a deficiency in Wine. You may want to check the Application Datbaase for tips about running this application.

    If any of the Forex Signals support team can help that would be great, anyone who knows how to fix this would be appreciated also!



    Unhandled exception: unimplemented function api-ms-win-core-sysinfo-l1-2-1..GetSystemTimePreciseAsFileTime called in 32-bit code (0x7b82d0e2).
    Register dump:
    CS:001b SS:0023 DS:0023 ES:0023 FS:1007 GS:000f
    EIP:7b82d0e2 ESP:0033fd14 EBP:0033fd88 EFLAGS:00000202( - -- I - - - )
    EAX:7b818649 EBX:7b82d06e ECX:00000000 EDX:00000000
    ESI:00000002 EDI:000000cb
    Stack dump:
    0x0033fd14: 0033fdb4 00000008 0000003c 80000100
    0x0033fd24: 00000001 00000000 7b82d0e2 00000002
    0x0033fd34: 45ce2315 45ce23a3 000007d8 00939880
    0x0033fd44: 0090e998 0033fd70 45ce0000 0033fd84
    0x0033fd54: ffffffff 0033fda8 7b849a6c 009f12c8
    0x0033fd64: 00004000 7b817d6d 7b849a6c 45ce0000
    0200: sel=1007 base=7ffc0000 limit=00000fff 32-bit rw-
    =>0 0x7b82d0e2 in kernel32 (+0x1d0e2) (0x0033fd88)
    1 0x45ce22d0 in api-ms-win-core-sysinfo-l1-2-1 (+0x22cf) (0x0033fdc4)
    2 0x45ce20d9 in api-ms-win-core-sysinfo-l1-2-1 (+0x20d8) (0x0033fde8)
    3 0x005743b0 in terminal (+0x1743af) (0x0033fe04)
    4 0x00574485 in terminal (+0x174484) (0x0033fe1c)
    5 0x0082cba4 in terminal (+0x42cba3) (0x0033fe6c)
    6 0x00568615 in terminal (+0x168614) (0x0033feb0)
    7 0x7b85229c in kernel32 (+0x4229b) (0x0033fec8)
    8 0x7b855d07 in kernel32 (+0x45d06) (0x0033ff08)
    9 0x7bc6e63c (0x0033ff28)
    10 0x7bc6f63a (0x0033ffa8)
    11 0x7bc6e602 (0x0033ffc8)
    12 0x7bc4561e (0x0033ffe8)
    0x7b82d0e2: subl $4,%esp
    Module Address Debug info Name (41 modules)
    PE 400000- 2b87000 Export terminal
    PE 420a0000-420a4000 Deferred ws2_32
    PE 42390000-4239b000 Deferred winmm
    PE 423f0000-423f4000 Deferred version
    PE 426b0000-426b4000 Deferred msacm32
    PE 426d0000-426d3000 Deferred msimg32
    PE 44920000-4494e000 Deferred user32
    PE 44a60000-44a64000 Deferred gdi32
    PE 44b80000-44b84000 Deferred advapi32
    PE 44bf0000-44bf8000 Deferred ole32
    PE 44d40000-44d44000 Deferred rpcrt4
    PE 44dd0000-44dd4000 Deferred dbghelp
    PE 44e30000-44e34000 Deferred psapi
    PE 44e50000-44e56000 Deferred winhttp
    PE 44e90000-44e95000 Deferred jsproxy
    PE 44eb0000-44eb7000 Deferred oleaut32
    PE 44ff0000-44ff4000 Deferred gdiplus
    PE 45090000-45094000 Deferred shlwapi
    PE 45110000-45116000 Deferred crypt32
    PE 451a0000-451a6000 Deferred winspool
    PE 451e0000-452ef000 Deferred shell32
    PE 453e0000-45400000 Deferred comctl32
    PE 454f0000-454f4000 Deferred uxtheme
    PE 45520000-45524000 Deferred oledlg
    PE 45540000-45552000 Deferred comdlg32
    PE 455c0000-455cb000 Deferred urlmon
    PE 45660000-45664000 Deferred wininet
    PE 456d0000-456d4000 Deferred mpr
    PE 456f0000-456f4000 Deferred wsock32
    PE 45710000-45714000 Deferred iphlpapi
    PE 45730000-45733000 Deferred secur32
    PE 45770000-45773000 Deferred netapi32
    PE 457a0000-457a6000 Deferred oleacc
    PE 457d0000-457d4000 Deferred imm32
    PE 45880000-45884000 Deferred winex11
    PE 45aa0000-45aa3000 Deferred api-ms-win-core-synch-l1-2-0
    PE 45ab0000-45ab3000 Deferred api-ms-win-core-fibers-l1-1-1
    PE 45ac0000-45ac3000 Deferred api-ms-win-core-localization-l1-C:\windows\system32\api-ms-win-core-localization-l1-2-1.dll
    PE 45ce0000-45ce3000 Export api-ms-win-core-sysinfo-l1-2-1
    PE 7b810000-7b866000 Export kernel32
    PE 7bc10000-7bc14000 Deferred ntdll
    process tid prio (all id:s are in hex)
    00000008 terminal.exe
    0000003e 0
    0000000d 0
    00000045 0
    00000040 -1
    0000003d 0
    0000003c 0
    0000003b -1
    0000003a 0
    00000039 0
    00000038 0
    00000037 0
    00000036 0
    00000035 0
    00000034 0
    00000033 0
    00000032 0
    00000031 0
    00000030 0
    0000002f 0
    0000002e 0
    00000023 0
    00000022 0
    00000009 0
    0000000e services.exe
    0000001d 0
    0000001c 0
    00000014 0
    00000010 0
    0000000f 0
    00000012 winedevice.exe
    0000001b 0
    00000018 0
    00000017 0
    00000013 0
    00000019 plugplay.exe
    0000001f 0
    0000001e 0
    0000001a 0
    00000020 explorer.exe
    00000021 0
    00000024 rpcss.exe
    0000002c 0
    0000002b 0
    0000002a 0
    00000029 0
    00000028 0
    00000026 0
    00000025 0
    00000043 (D) C:\users\Waleed\Application Data\MetaQuotes\WebInstall\mt4clw\terminal.exe
    00000044 0 <==
    System information:
    Wine build: wine-1.7.36
    Platform: i386
    Host system: Darwin
    Host version: 15.0.0
    Last edited by Waleed121; 04-12-2016, 05:06 PM.

  • #2
    Why not use the new native mt4 client for Mac instead of using wine?
    It is available, right?

    Like this one =>

    Sent from my Nexus 6 using Tapatalk
    Last edited by Okda; 04-12-2016, 05:07 PM.


    • #3
      Originally posted by Okda View Post
      Why not use the new native mt4 client for Mac instead of using wine?
      It is available, right?

      Sent from my Nexus 6 using Tapatalk
      Please provide me a source / link so I can have a look, this has evidently given me issue with attaching EA's and whatever indicator I wish to attach to my chart.

      Thanks Okda. I downloaded ICM's Mac MT4 version....


      • #4
        Originally posted by Okda View Post
        Why not use the new native mt4 client for Mac instead of using wine?
        It is available, right?

        Like this one =>

        Sent from my Nexus 6 using Tapatalk
        It's no different to ICM MT4 surely?


        • #5
          Don't think so, I think just customized with the broker's server and logo like the windows mt4

          Sent from my Nexus 6 using Tapatalk


          • #6
            Originally posted by Okda View Post
            Don't think so, I think just customized with the broker's server and logo like the windows mt4

            Sent from my Nexus 6 using Tapatalk
            Same with ICM, thats where I downloaded it... I could give it a go but I'm sure someone has seen this error before


            • #7
              Fixed by reinstalling the MT4 from ICM

              It seems they updated a new MT4 version as previously it was not supported now mentions;

              "Compatible with latest MAC OS X EL Captain"



              • #8
                Glad you've fixed your MT4, it gives out a lot of problems in my Macbook Pro as well. Bought Parallels and install Windows 10 in it and now it run flawlessly.


                • #9
                  I seem itís a manual problem of your broker! I never faced this type of technical issue in my live trading chart! By the way, MT4 trsading platform is my favorite trading platform! I started my demo with Mt4 trading platform and till now I am using Mt4 trading platform so willingly! Since I get all of technical support into Mt4 thatís way, I never tried others!


                  • #10
                    I run MetaTrader on my MacBook Air and never had problems with it. It runs smoothly. You know, the MacBook was the first investment with the money I made on Forex and I'm better to work faster and more productive now. My Windows PC was slow, and although MetaTrader was running smoothly by itself, when opening other apps it became slower. I couldn't even use the Page Down and Page Up. Mac is another story. No matter how many apps I run simultaneously, it still runs like only one is open. And the Page Down and Page Up work so as well.
                    How to use Page Down and Page Up on a Mac?

                    Last edited by Iluminatis; 11-22-2019, 10:37 AM.