• Managed Accounts
  • Trusted Brokers
  • Blog
  • Forex Forum

Announcement

Collapse
No announcement yet.

Using meta 4 on Android - troubleshooting

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Using meta 4 on Android - troubleshooting

    I have an android tablet and smartphone. At one time, I could make trades on meta 4 using these devices. Then for some reason I could not. I have uninstalled and reinstalled meta 4 but continue to have the following problem. Though I can see everything, I can NOT open nor close trades. I do not know what to do to enable that. I have no problem with my meta 4 on my PC, only my androids. Anyone know what I do to solve this problem?

  • #2
    Are you by any chance using your investor password?

    Comment


    • #3
      Also did you update your mt4 from play market?

      Sent from my GT-N7000 using Tapatalk

      Comment


      • #4
        Yes, I am using my password and I downloaded a fresh install from google stores for meta4

        Comment


        • #5
          Go to your Brokers website from your phone and download the MT4 from them.... the MT4 on Google Play store is MetaTrader only. It's not specific to your broker.
          DETACH YOUR MT4 CHARTS Now Available. - Trading as a hobby is realistic.

          Comment


          • #6
            Never heard that before, AFAIK they are all the same, since most of broker's link will take you to the play store webpage of the generic version

            Sent from my GT-N7000 using Tapatalk

            Comment


            • #7
              I have contacted my broker to see if they know why. I was able to open or close trades on my androids and then it stopped giving me that option without me changing anything. Hopefully, my broker has some idea. I have icmarkets for a broker. I have no problems on my desktop.

              Comment


              • #8
                My vote is that you used investor password instead of the master password

                Sent from my Nexus 5 using Tapatalk

                Comment


                • #9
                  Yes, was using master password and not account. Problem solved! Bad Brain. Thanks everyone.

                  Comment

                  Working...
                  X